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EPRI Presents Electrification 2026: 
International Conference & Exposition 
POWERING PROGRESS 

June 23–25, 2026 • Baltimore, Maryland

We’re excited to welcome you back 
for Electrification 2026, where global 
thought leaders and cutting-edge 
innovators converge to shape the future 
of energy. 

From across the electrification spectrum, 
we come together to collaborate, learn 
and lead. This is where ideas spark 
progress. Where organizations advance 
their goals. And where inspiration fuels 
the transformation of tomorrow’s energy 
systems by POWERING PROGRESS.

Join us in Baltimore — and be part of the 
momentum driving the electrified future.

Thank You for Joining Us — Now Let’s 
Spread the Word!

We’re grateful for your participation and are excited to 
have you on this journey with us. Now let’s maximize your 
impact at Electrification 2026!

To make it easy, we’ve created a Marketing Toolkit packed 
with everything you need:

•	 Newsletter copy

•	 Social media templates and post ideas

•	 Website and calendar content

•	 Event graphics, logos, banner ads,  
and branding guidelines 
 

	» Bookmark our official website to stay in the loop

	» Join our mailing list for key updates

	» Follow EPRI on social media: 

	» And don’t forget to use our official hashtags: 	

Let’s make this the most impactful and well-connected 
Electrification event yet — see you in Baltimore!

@EPRINews #ElectricTogether www.electrification2026.com

#Electrification2026   #ElectricTogether   #PoweringProgress

https://www.electrification2022.com/
https://www.electrification2026.com/
https://www.electrification2026.com/subscribe
https://www.electrification2022.com/
https://www.linkedin.com/company/epri/posts/?feedView=all
https://www.facebook.com/EPRI
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EPRI’s Electrification 2026 International Conference and Exposition 
returns June 23–25, 2026 in Baltimore, Maryland. This premier event 
will once again place attendees at the forefront of innovation across 
the electrification and decarbonization landscape.

With focused tracks spanning:

•	 Department of Defense

•	 Buildings & Technology

•	 Overcoming Challenges to Industrial Electrification

•	 Electrified Agriculture – Watts Growing?

•	 Affordability & Community Engagement

•	 Transportation

•	 Alternative Fuels

Electrification 2026 is where insights are shared, solutions are 
forged, and the future of energy comes to life. Designed for utilities, 
manufacturers, policymakers, researchers, and community leaders, 
this conference is your opportunity to connect, collaborate, and lead.

Visit the official website for full details:  
www.electrification2026.com

Calendar Listing
EVENT NAME:	 Electrification 2026 International Conference & Exposition

HOST:		  EPRI

LOCATION:	 Baltimore Convention Center, Baltimore, Maryland

DATE:		  June 23-25, 2026

WEBSITE: 	 www.electrification2026.com

DESCRIPTION: 	 EPRI’s Electrification 2026 conference and expo returns 	
		  June 23-25, 2026 in beautiful Baltimore, Maryland. The 	
		  event is designed to keep attendees on the cutting edge  
		  of developments in electrification and decarbonization. 	
		  #ElectricTogether #PoweringProgress		

		  Tracks include:

Marketing Collateral 

•	 Department of Defense

•	 Buildings & Technology

•	 Overcoming Challenges to Industrial Electrification

•	 Electrified Agriculture – Watts Growing?

•	 Affordability & Community Engagement 

•	 Transportation

•	 Alternative Fuels

This event is tailored for utilities, manufacturers, 
policymakers, academics, and community members.

https://www.electrification2022.com/
https://www.electrification2026.com/
http://www.electrification2026.com
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Web Banner Ads
Save Images
Click on the image to launch it in a browser window. Then open the file in a PDF program and edit the footer copy appropriately.  
Any edits made to banners should be in Arial font. Export the banner as an image by going to File > Export To > Image > PNG.

Microbar 
88 × 31 pxButton 2 

120 × 60 pxButton 1 
120 × 90 px

Special 2 
300 x 80 px

Special 1 
260 x 240 px

Wide Skyscraper  
160 × 600 px

Large Square 1080 x 1080 px

Leaderboard 728 × 90 px

Large Rectangle 336 × 280 px

Medium Rectangle 300 × 250 px

Skyscraper  
120 × 600 px

https://www.electrification2022.com/
https://www.electrification2026.com/images/media/toolkit/E26-Banner-88x31.png
https://www.electrification2026.com/images/media/toolkit/E26-Banner-120x60.png
https://www.electrification2026.com/images/media/toolkit/E26-Banner-120x60.png
https://www.electrification2026.com/images/media/toolkit/E26-Banner-300x80.pdf
https://www.electrification2026.com/images/media/toolkit/E26-Banner-260x240.pdf
https://www.electrification2026.com/images/media/toolkit/E26-Banner-1080x1080.pdf
https://www.electrification2026.com/images/media/toolkit/E26-Banner-336x280.pdf
https://www.electrification2026.com/images/media/toolkit/E26-Banner-300x250.pdf
https://www.electrification2026.com/images/media/toolkit/E26-Banner-728x90.pdf
https://www.electrification2026.com/images/media/toolkit/E26-Banner-160x600.pdf
https://www.electrification2026.com/images/media/toolkit/E26-Banner-120x600.pdf
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LinkedIn Posting Best Practices for Electrification 2026

Post 1
We’re⚡energized⚡about Electrification 
2026: Join Us! At [Company/Organization 
Name], [we’re] [I’m] proud to be a 
[sponsor] [speaker] [exhibitor] [attendee] 
of the Electrification 2026 International 
Conference & Exposition, hosted by 
EPRI June 23-25 in Baltimore, MD  
#ElectricTogether #Electrification2026 

The conference will address the latest 
questions on electrifying numerous industry 
sectors, and explore the answers to help 
advance electrification initiatives and create 
sustainable solutions. For more information, 
check out the agenda:  
www. electrification2026.com/program 

⚡Register today⚡to accelerate together 
for an electrified future 

@EPRINews #ElectricTogether 
#PoweringProgress  
www.electrification2026.com

Post 2
Want unparalleled access to industry influencers, 
compelling and insightful agenda sessions, 
a comprehensive exposition, and multiple 
networking functions?

[We’re] [I’m] proud to [sponsor] [speak as part 
of] [exhibit at] [attend] ⚡Electrification 2026⚡ 
#ElectricTogether #PoweringProgress

Come join us for a program that covers industrial 
electrification, decarbonized transportation, 
smart buildings, community impacts, national 
defense, low carbon fuels, grid impacts, and 
indoor/ controlled environmental agriculture.  
www.electrification2026.com/program You will 
have continuous opportunities to learn, share 
and connect in person with fellow industry 
professionals, 

⚡Register today⚡  
www.electrification2026.com/registration

@EPRINews #ElectricTogether 
#PoweringProgress 

Post 3
We can’t wait to meet you in person at 
upcoming ⚡Electrification 2026⚡! As a 
[sponsor] [speaker] [exhibitor] [attendee], 
Electrification 2026 helps [us] [me] stay at 
the forefront of how we access our energy 
and #PoweringProgress. 

Connect with us at the conference and 
help expand Electrification’s significant 
benefits. Interested? For full details, 
including agenda, registration, exhibit, and 
sponsorship opportunities, visit  
www.electrification2026.com.

⚡Register today⚡ to accelerate  
together for an electrified future.  
www.electrification2026.com/registration

@EPRINews #ElectricTogether 
#PoweringProgress

Post 4
#PoweringProgress is not just a slogan 
— at Electrification 2026 we’re diving 
deep into how our electrified future 
can deliver economic benefits to 
empower local communities and uplift 
all segments of society. As a [sponsor] 
[speaker] [exhibitor] [attendee], 
Electrification 2026 helps [us] [me] see 
the full picture of electrification and how 
it will help us solve global challenges 
like climate change while reducing 
inequities at the community level.

For more information, check out 
the agenda:  
www.electrification2026.com/program

⚡Register today ⚡

Save Image
Click on the image to launch it in 
a browser window. Then open 
the file in a PDF program and edit 
the footer copy appropriately. Any 
edits made to banners should be 
in Arial font. Export the banner as 
an image by going to File > Export 
To > Image > PNG.

To maximize reach and engagement, we recommend the following:

Best Posting Times:  
Tuesdays, Wednesdays,  
and Thursdays between  
9–11 AM ET

Recycling is Encouraged! 
Reposting the same 
content every 4 weeks can 
significantly boost visibility. 
Feel free to rotate and reuse 
these posts across your 
network to help us spread 
the word!

Suggested Strategy: 
Schedule your three 
Electrification2026 
promotional posts to 
go out consecutively 
throughout the week 
using the timing above 
for optimal impact. 

Use Hashtags Wisely: 
Include 3–5 relevant 
hashtags per post. Be 
sure to include our 
official event hashtags: 
#Electrification2026 
#PoweringProgress

Please consider adding this 
banner for each LinkedIn post. 

https://www.electrification2022.com/
http://www. electrification2026.com/program 
http://www.electrification2026.com
http://www.electrification2026.com/program
http://www.electrification2026.com/registration
http://www.electrification2026.com.
http://www.electrification2026.com/registration
http://www.electrification2026.com/program 
https://www.electrification2026.com/images/media/toolkit/E26-Banner-250x300.pdf
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General Marketing Posts

Pre Event
We’re ⚡Energized ⚡ about Electrification 2026: Join 
Us June 23-25, 2026 to showcase [brief description 
of innovations/products/services]. We can’t wait to 
connect with you there!

•	 Ready to connect with industry leaders at 
#Electrificaion2026? [Company Name] will 
be showcasing [brief description of products/
services]. Let’s talk about how we can collaborate!

•	 We’re gearing up for #Electrification2026! Here’s 
a sneak peek of what we’re bringing to the event. 
Be sure to visit us at booth [booth number] to 
learn about [product/service/innovation]. Let’s 
connect and innovate together!

•	 Ready to spark ⚡ new connections? [Company 
Name] will be at #Electrification2026  
June 23-25 in Baltimore, MD. Visit us at booth 
[booth number] to meet our experts, share ideas, 
and explore new opportunities. Let’s collaborate 
for a brighter future!

During Event
•	 Things are buzzing ⚡ on Day 1 at 

#Electrification2026! We’re at booth 
[booth number] showcasing [brief description of 
innovations/products/services]. Stop by to learn 
how we can help you [solve specific problem or 
achieve specific goal]!

•	 Day 2 at #Electrification2026 is in full swing! 
Be sure to stop by booth [booth number] to 
explore [Company Name]’s [product/service]. 
We’re excited to show you how we can help you 
[benefit/goal].

•	 Wrapping up an amazing #Electrification2026! 
There’s still time to visit booth [booth number] 
today and check out [product/service] from 
[Company Name]. Let’s innovate together!

Post Event
•	 Thank you to everyone who visited us at 

#Electrification2026! It was an incredible event, 
and we loved showcasing the latest in Powering 
Progress. Missed us? Feel free to reach out at 
[contact details] to learn more about how our 
products and solutions!

•	 What a fantastic experience at 
#Electrification2026! We had a great time 
meeting so many amazing people and discussing 
the future of energy. If you didn’t have a chance 
to stop by our booth, don’t worry—let’s connect 
and continue the conversation!

•	 #Electrification2026 may be over, but the 
conversation doesn’t stop here! Thanks to 
everyone who visited us to talk about Powering 
Progress. If you’re interested in learning more or 
have any questions, reach out to us today.

https://www.electrification2022.com/
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Post 1
[We’re] [I’m] proud to [sponsor] [speak at] 
[exhibit at] [attend] @EPRINews’ 
Electrification 2026! #PoweringProgress 

Tracks include industry, transportation, 
buildings, communities, defense, 
electrofuels, transmission, and agriculture. 
Register today at electrification2026.com

Post 2
[We’re] [I’m] ⚡energized⚡ to [sponsor] 
[speak at] [exhibit at] [attend] @
EPRINews’ Electrification 2026 conference 
June 23‑25 in Baltimore, MD. Connect with 
other leaders working to #electrify and 
#decarbonize our society. Register today! 
#ElectricTogether electrification2026.com

Post 3
This year [we are] [I am] thrilled to 
[sponsor] [speak at] [exhibit at] [attend] 
@EPRINews’ Electrification 2026! 
Come connect in person with the 
leaders working for a future of 
#electrification and #decarbonization. 
⚡Register today⚡ #PoweringProgress 
electrification2026.com

Post 4
[We’re] [I’m] proud to [sponsor] 
[speak at] [exhibit at] [attend] 
@ EPRINews’ Electrification 2026 
conference June 23‑25 in Baltimore, 
MD. Visit us to meet our experts, share 
ideas, and explore new opportunities. 
Let’s collaborate for a brighter future! 
electrification2026.com

Twitter/X Posting Best Practices for Electrification 2026 
To help your posts gain maximum traction, keep the following tips in mind:

Best Posting Times:  
9–11 AM ET 
6–9 PM ET 
These windows are 
proven to generate the 
highest engagement 
on Twitter/X.

Recycling is Encouraged! 
Reposting every 4 weeks 
helps increase visibility 
and engagement—don’t 
hesitate to re-share your 
tweets throughout the 
campaign period!

Suggested Strategy: 
Three Electrification 
2026 tweets to post 
consecutively throughout 
the week, during the 
time slots listed above.

Hashtags = Visibility: 
Use up to 3 relevant 
hashtags, and 
always include 
#Electrification2026 to 
stay connected to the 
broader conversation.  

Please consider adding this banner for each X/Twitter 
post. Up to 4 images can be added to each post, so we 
encourage you to add both this banner and an image of 
your organization.

Save Image
Click on the image to launch 
it in a browser window. Then 
open the file in a PDF program 
and edit the footer copy 
appropriately. Any edits made 
to banners should be in Arial 
font. Export the banner as 
an image by going to File > 
Export To > Image > PNG.

https://www.electrification2022.com/
https://www.electrification2026.com/images/media/toolkit/E26-Banner-250x300.pdf
http://electrification2026.com
http://electrification2026.com
http://electrification2026.com
http://electrification2026.com
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Thank you again for your support of 
the Electrification 2026 International 
Conference & Exposition.

Get excited for Electrification 2026!  
Spread the word by sharing this video. 

If you have any questions or need 
additional information about this 
marketing toolkit, please contact our 
Communications Lead: 
Kristin Battenfield  
kristin@kbatcommunications.com

We appreciate your partnership in 
helping to spread the word!

https://www.electrification2022.com/
https://app.box.com/file/1513430022013?s=nkuvvm7yt7pzl55sezme8x81y8s4x5sq
mailto:kristin%40kbatcommunications.com?subject=Electrification%202026

